The scheduled maintenance has been completed. All systems have been tested and are fully operational again.
Posted Jan 26, 2026 - 08:26 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 26, 2026 - 08:00 UTC
Scheduled
We're making some upgrades to our North America (NA) platform and will be performing maintenance during the mentioned time. Interruptions are kept to a minimum but may be up to 5 minutes at a time. For further information regarding changes please contact our support team.
Posted Jan 19, 2026 - 14:21 UTC
This scheduled maintenance affected: NA | North America (SBC na1).